Search This Blog

Tuesday, February 17, 2015

How to find from which disk the system has booted in HP-UX

HP-UX 11i v1 (11.11)

On HP-UX 11.11 systems execute the following command to determine the boot device.

# echo "boot_string/S" | adb -k /stand/vmunix /dev/kmem
Example:

# echo "boot_string/S" | adb -k /stand/vmunix /dev/kmem
boot_string:
boot_string:    disk(0/2/1/0.6.0.0.0.0.0;0)/stand/vmunix

HP-UX 11i v2 (11.23)

On HP-UX 11.23 systems execute the following command to determine the boot device.


# echo "bootdev/X" | adb -o /stand/vmunix /dev/kmem 
bootdev: 
bootdev:        0x1f######  

Example:

# echo "bootdev/X" | adb -o /stand/vmunix /dev/kmem 
bootdev: 
bootdev:        0x1f021002 
ll /dev/dsk/* | grep 021002
brw-r-----   1 bin        sys         31 0x021002 Oct 28  2004 /dev/dsk/c2t6d0

HP-UX 11i v3 (11.31)

On HP-UX 11i v3 systems use Agile View device naming scheme. Execute the following command to determine the boot device.

# echo "bootdev/X" | adb -o /stand/vmunix /dev/kmem
bootdev:
bootdev:        0x10000##

Example:

# echo "bootdev/X" | adb -o /stand/vmunix /dev/kmem 
bootdev: 
bootdev:        0x1000004 
# ll /dev/disk/* | grep 000004
brw-r-----   1 bin        sys          1 0x000004 Jul  1 15:00 /dev/disk/disk11
Current boot configuration

Sometimes, instead of verify the disk from were the disk has booted, is only necessary to check the current boot configuration status (non mirrored environment), this can be accomplish using ioscan and setboot commands.

HP-UX 11.11 (PA-RISC)
Example

# ioscan -fnkH `setboot | awk -F":" '/Primary bootpath/ {print $2}'`
Class     I  H/W Path       Driver   S/W State   H/W Type     Description
==========================================================================
disk      0  1/0/1/0/0/1/1.6.0  sdisk    CLAIMED     DEVICE       HP 73.4GST373307LC
                           /dev/dsk/c1t6d0   /dev/rdsk/c1t6d0

HP-UX 11.23 (Integrity)
Example

# ioscan -fnkH `setboot | awk -F":" '/Primary bootpath/ {print $2}'`
Class     I  H/W Path       Driver S/W State   H/W Type     Description
=======================================================================
disk      4  1/0/0/3/0.6.0  sdisk CLAIMED     DEVICE       HP 36.4GMAS3367NC
                           /dev/dsk/c0t6d0     /dev/rdsk/c0t6d0
                           /dev/dsk/c0t6d0s1   /dev/rdsk/c0t6d0s1
                           /dev/dsk/c0t6d0s2   /dev/rdsk/c0t6d0s2
                           /dev/dsk/c0t6d0s3   /dev/rdsk/c0t6d0s3

Thank you for Reading,
For Reading other article, visit to “https://sites.google.com/site/unixwikis/

No comments:

Post a Comment