Create initial vPar
Check if the vpar software is installed
# swlist|grep T1335CC
T1335CC A.05.01.03 HP-UX Virtual Partitions for 11.31
Find the console LBA.
# ioscan kfnC tty
Class I H/W Path Driver S/W State H/W Type Description
===================================================================
tty 0 1/0/0/0/0 asio0 CLAIMED INTERFACE PCI SimpleComm (103c1290)
/dev/diag/mux0 /dev/mux0 /dev/tty0p0
tty 1 1/0/0/0/1 asio0 CLAIMED INTERFACE PCI Serial (103c1048)
/dev/GSPdiag1 /dev/mux1 /dev/tty1p2
/dev/diag/mux1 /dev/tty1p0 /dev/tty1p4
Find empty I/O slot for each vPar
# olrad -q
Driver(s)
Capable
Slot Path Bus Max Spd Pwr Occu Susp OLAR OLD Max Mode
Num Spd Mode
0-0-1-1 1/0/8/1 396 133 133 Off No N/A N/A N/A PCI-X PCI-X
0-0-1-2 1/0/10/1 425 133 133 Off No N/A N/A N/A PCI-X PCI-X
0-0-1-3 1/0/12/1 454 133 133 Off No N/A N/A N/A PCI-X PCI-X
0-0-1-4 1/0/14/1 483 133 66 On Yes No Yes Yes PCI-X PCI
0-0-1-5 1/0/6/1 368 133 66 On Yes No Yes Yes PCI-X PCI
0-0-1-6 1/0/4/1 340 133 133 On Yes No Yes Yes PCI-X PCI-X
0-0-1-7 1/0/2/1 312 133 133 On Yes No Yes Yes PCI-X PCI-X
0-0-1-8 1/0/1/1 284 133 66 On Yes No Yes Yes PCI-X PCI
Determine how many CPUs are available in your nPar
# ioscan -fkC processor
Class I H/W Path Driver S/W State H/W Type Description
========================================================================
processor 0 1/120 processor CLAIMED PROCESSOR Processor
processor 1 1/121 processor CLAIMED PROCESSOR Processor
processor 2 1/122 processor CLAIMED PROCESSOR Processor
processor 3 1/123 processor CLAIMED PROCESSOR Processor
Find a LAN adapter
# lanscan
Hardware Station Crd Hdw Net-Interface NM MAC HP-DLPI DLPI
Path Address In# State NamePPA ID Type Support Mjr#
1/0/1/1/0/4/0 0x000F202BC457 0 UP lan0 snap0 1 ETHER Yes 119
1/0/6/1/0 0x00306EF49E73 1 UP lan1 snap1 2 ETHER Yes 119
1/0/14/1/0 0x00306EF41FAF 2 UP lan2 snap2 3 ETHER Yes 119
Find the disk
# ioscan -fnC disk
Class I H/W Path Driver S/W State H/W Type Description
=======================================================================
disk 1 0/0/0/3/0.5.0 sdisk CLAIMED DEVICE HP 146 GST3146807LC
/dev/dsk/c0t5d0 /dev/dsk/c0t5d0s2 /dev/rdsk/c0t5d0 /dev/rdsk/c0t5d0s2
/dev/dsk/c0t5d0s1 /dev/dsk/c0t5d0s3 /dev/rdsk/c0t5d0s1 /dev/rdsk/c0t5d0s3
disk 0 0/0/0/3/0.6.0 sdisk CLAIMED DEVICE HP 146 GMAP3147NC
/dev/dsk/c0t6d0 /dev/dsk/c0t6d0s2 /dev/rdsk/c0t6d0 /dev/rdsk/c0t6d0s2
/dev/dsk/c0t6d0s1 /dev/dsk/c0t6d0s3 /dev/rdsk/c0t6d0s1 /dev/rdsk/c0t6d0s3
disk 4 1/0/0/3/0.6.0 sdisk CLAIMED DEVICE HP 146 GMAP3147NC
/dev/dsk/c8t6d0 /dev/dsk/c8t6d0s2 /dev/rdsk/c8t6d0 /dev/rdsk/c8t6d0s2
/dev/dsk/c8t6d0s1 /dev/dsk/c8t6d0s3 /dev/rdsk/c8t6d0s1 /dev/rdsk/c8t6d0s3
disk 6 1/0/0/3/1.2.0 sdisk CLAIMED DEVICE HP DVD-ROM 305
/dev/dsk/c9t2d0 /dev/rdsk/c9t2d0
disk 5 1/0/1/1/0/1/1.6.0 sdisk CLAIMED DEVICE HP 146 GMAP3147NC
/dev/dsk/c11t6d0 /dev/dsk/c11t6d0s2 /dev/rdsk/c11t6d0 /dev/rdsk/c11t6d0s2
/dev/dsk/c11t6d0s1 /dev/dsk/c11t6d0s3 /dev/rdsk/c11t6d0s1 /dev/rdsk/c11t6d0s3
# setboot
Primary bootpath : 0/0/0/3/0.0x5.0x0 (/dev/rdisk/disk3)
HA Alternate bootpath : 1/0/1/1/0/1/1.0x6.0x0 (/dev/rdisk/disk8)
Alternate bootpath : 0/0/0/3/0.0x5.0x0 (/dev/rdisk/disk3)
Autoboot is ON (enabled)
Create the vPar
# vparcreate -p vpar0 \
-a io:1.0.1 \
-a io:1.0.1.1.0.1.1.6.0:BOOT \
-a cpu::1 -a cpu:::1:4 \
-a mem::2048 -a mem::1024:float \
-a cell:1:mem::512 \
-a cell:1:mem::256:float \
-g ilm:256:y -g clm:128:y
-a io:1.0.1.1.0.1.1.6.0:BOOT is boot disk of nPar only, this is only when we are creating first vpar in an nPar.
Check the configuration
# vparstatus -p vpar0
vparstatus: Warning: Not accessing live monitor database, Requested resources shown.
[Virtual Partition]
Boot
Virtual Partition Name State Attributes Kernel Path Opts
============================== ===== ============ ======================= =====
vpar0 N/A Dyn,Auto,Nsr /stand/vmunix
[Virtual Partition Resource Summary]
CPU Num Num Memory Granularity
Virtual Partition Name Min/Max CPUs IO ILM CLM
============================== ======= ==== ==== ========== ==========
vpar0 1/ 4 1 2 256 128
Memory (MB)
ILM CLM
# User # User
Virtual Partition Name Ranges/MB Total MB Ranges/MB Total MB
============================== ====================== ======================
vpar0 0/ 0 3072 0/ 0 768
Modify the auto file on the nPars boot disk to automaticaly run vpmon
# lvlnboot -v <- find your boot disk
# mkboot -a "boot vpmon -a" /dev/rdisk/disk#
Change boot mode to vPars
# vparenv -m vPars
# vparenv (verification)
# vparefiutil -u
# vparefiutil (verification)
Reboot the box
# reboot
No comments:
Post a Comment